$re = '/(?<!\.\d\d)\n/';
$str = 'enter This line ends with text
this line ends with a number: 55
this ends with 2-decimal number: 5.00
here\'s 22.22, not at the end of the line
';
$subst = ";\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;