#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\.\d\d)\n"
Local $sString = "enter This line ends with text" & @CRLF & _
"this line ends with a number: 55" & @CRLF & _
"this ends with 2-decimal number: 5.00" & @CRLF & _
"here's 22.22, not at the end of the line" & @CRLF & _
""
Local $sSubst = ";\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)