import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\.\\d\\d)\\n";
final String string = "enter This line ends with text\n"
+ "this line ends with a number: 55\n"
+ "this ends with 2-decimal number: 5.00\n"
+ "here's 22.22, not at the end of the line\n";
final String subst = ";\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}