use strict;
my $str = 'enter This line ends with text
this line ends with a number: 55
this ends with 2-decimal number: 5.00
here\'s 22.22, not at the end of the line
';
my $regex = qr/(?<!\.\d\d)\n/p;
my $subst = ';\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";