import Foundation
let pattern = #"(?<!\.\d\d)\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
enter This line ends with text
this line ends with a number: 55
this ends with 2-decimal number: 5.00
here's 22.22, not at the end of the line
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)