using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.\d\d)\n";
string substitution = @";\n";
string input = @"enter This line ends with text
this line ends with a number: 55
this ends with 2-decimal number: 5.00
here's 22.22, not at the end of the line
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}