#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+\.?\d*)\/(\d+\.?\d*)"
Local $sString = "This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10" & @CRLF & _
"./." & @CRLF & _
"1/100" & @CRLF & _
"0.99/10.0" & @CRLF & _
"/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")