re = /(\d+\.?\d*)\/(\d+\.?\d*)/m
str = 'This is Logan, the Chow who lived. He solemnly swears he\'s up to lots of good. 9.75/10
./.
1/100
0.99/10.0
/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end