using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.?\d*)\/(\d+\.?\d*)";
string input = @"This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10
./.
1/100
0.99/10.0
/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}