// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+\.?\d*)\/(\d+\.?\d*)").unwrap();
let string = "This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10
./.
1/100
0.99/10.0
/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}