$re = '/(\d+\.?\d*)\/(\d+\.?\d*)/m';
$str = 'This is Logan, the Chow who lived. He solemnly swears he\'s up to lots of good. 9.75/10
./.
1/100
0.99/10.0
/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);