const regex = /(\d+\.?\d*)\/(\d+\.?\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.?\\d*)\\\/(\\d+\\.?\\d*)', 'gm')
const str = `This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10
./.
1/100
0.99/10.0
/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}