import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.?\\d*)\\/(\\d+\\.?\\d*)";
final String string = "This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10\n"
+ "./.\n"
+ "1/100\n"
+ "0.99/10.0\n"
+ "/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}