using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)";
string input = @"1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}