package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)`)
var str = `1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}