use strict;
my $str = '1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142';
my $regex = qr/(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}