import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\.(\\d+)\\.(\\d+)(\\-beta.\\d)*\\-(\\d+)";
final String string = "1.6.8-141\n"
+ "1.6.8-beta.1-141\n"
+ "1.5.2-130\n"
+ "1.3.0-120\n"
+ "1.6.8-beta.2-142";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}