$re = '/(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)/';
$str = '1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);