re = /(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)/
str = '1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end