import Foundation
let pattern = #"(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)