const regex = /(\d+)\.(\d+)\.(\d+)(\-beta.\d)*\-(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\.(\\d+)\\.(\\d+)(\\-beta.\\d)*\\-(\\d+)', 'g')
const str = `1.6.8-141
1.6.8-beta.1-141
1.5.2-130
1.3.0-120
1.6.8-beta.2-142`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}