# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[A-Z]+(?!19\b)\d*\b;?//gm;t' <<< "ABCD17; ABC18; ABCEF19; XYZ19; ABCDE
ABCEF199; XYZ1999; ABCDE"