import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z]+(?!19\\b)\\d*\\b;?";
final String string = "ABCD17; ABC18; ABCEF19; XYZ19; ABCDE\n\n"
+ "ABCEF199; XYZ1999; ABCDE";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}