use strict;
my $str = 'ABCD17; ABC18; ABCEF19; XYZ19; ABCDE
ABCEF199; XYZ1999; ABCDE';
my $regex = qr/\b[A-Z]+(?!19\b)\d*\b;?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";