const regex = /\b[A-Z]+(?!19\b)\d*\b;?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z]+(?!19\\b)\\d*\\b;?', 'gm')
const str = `ABCD17; ABC18; ABCEF19; XYZ19; ABCDE
ABCEF199; XYZ1999; ABCDE`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);