import Foundation
let pattern = #"\b[A-Z]+(?!19\b)\d*\b;?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABCD17; ABC18; ABCEF19; XYZ19; ABCDE
ABCEF199; XYZ1999; ABCDE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)