using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]+(?!19\b)\d*\b;?";
string substitution = @"";
string input = @"ABCD17; ABC18; ABCEF19; XYZ19; ABCDE
ABCEF199; XYZ1999; ABCDE";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}