#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b[A-Z]+(?!19\b)\d*\b;?"
Local $sString = "ABCD17; ABC18; ABCEF19; XYZ19; ABCDE" & @CRLF & _
"" & @CRLF & _
"ABCEF199; XYZ1999; ABCDE"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)