# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^;]*;([^;]*;)([^;]*;)(.*)$/$2$1$3/gm;t' <<< "a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n"