const regex = /^[^;]*;([^;]*;)([^;]*;)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^;]*;([^;]*;)([^;]*;)(.*)$', 'gm')
const str = `a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n`;
const subst = `$2$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);