use strict;
my $str = 'a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n';
my $regex = qr/^[^;]*;([^;]*;)([^;]*;)(.*)$/mp;
my $subst = '$2$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";