$re = '/^[^;]*;([^;]*;)([^;]*;)(.*)$/m';
$str = 'a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n';
$subst = "$2$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;