package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^;]*;([^;]*;)([^;]*;)(.*)$`)
var str = `a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n`
var substitution = "$2$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}