re = /^[^;]*;([^;]*;)([^;]*;)(.*)$/m
str = 'a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n'
subst = '$2$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result