import Foundation
let pattern = #"^[^;]*;([^;]*;)([^;]*;)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a;bb;c;D;e;fff
gg;h;ii;jj;kk;l;m;n
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)