# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)/$0 This value $3 ***$2/gi;t' <<< "111 is different from:
111 is different from:
123 is different from:
567."