import Foundation
let pattern = #"(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
111 is different from:
111 is different from:
123 is different from:
567.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0 This value $3 ***$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)