$re = '/(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)/i';
$str = '111 is different from:
111 is different from:
123 is different from:
567.';
$subst = "$0 This value $3 ***$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;