#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)"
Local $sString = "111 is different from:" & @CRLF & _
"111 is different from:" & @CRLF & _
"123 is different from:" & @CRLF & _
"567."
Local $sSubst = "$0 This value $3 ***$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)