using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)";
string substitution = @"$0 This value $3 ***$2";
string input = @"111 is different from:
111 is different from:
123 is different from:
567.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}