import re
regex = re.compile(r"(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)", flags=re.IGNORECASE)
test_str = ("111 is different from:\n"
"111 is different from:\n"
"123 is different from:\n"
"567.")
subst = "$0 This value $3 ***$2"
result = regex.sub(subst, test_str)
if result:
print(result)