const regex = new RegExp('(?m)^(\\d{3}) .+:(\\r?\\n)(?!\\1)(?=(\\d{3})\\b)', 'gi')
const str = `111 is different from:
111 is different from:
123 is different from:
567.`;
const subst = `$0 This value $3 ***$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);