using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_inherit = 'res\.partner'(?s:.*?)unique_code.*";
string input = @"_inherit = 'res.partner'
parent_company = fields.Many2one('res.partner', 'Parent Company')
unique_code = fields.Char(string='Unique client code', readonly=""1"",copy=False, index=True) ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}