$re = '/_inherit = \'res\.partner\'(?s:.*?)unique_code.*/m';
$str = '_inherit = \'res.partner\'
parent_company = fields.Many2one(\'res.partner\', \'Parent Company\')
unique_code = fields.Char(string=\'Unique client code\', readonly="1",copy=False, index=True) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);