import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_inherit = 'res\\.partner'(?s:.*?)unique_code.*";
final String string = "_inherit = 'res.partner' \n\n"
+ "parent_company = fields.Many2one('res.partner', 'Parent Company') \n"
+ "unique_code = fields.Char(string='Unique client code', readonly=\"1\",copy=False, index=True) ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}