using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$";
string input = @"1234-5678-9012-3412
5645-6789-7897-9879
87979879879798798
13156465487987
54654 231321 45654 464 3213 5464 ";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}