import Foundation
let pattern = #"^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234-5678-9012-3412
5645-6789-7897-9879
87979879879798798
13156465487987
54654 231321 45654 464 3213 5464
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}