const regex = /^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\d]{4})[\\-]([\\d]{4})[\\-]([\\d]{4})[\\-]([\\d]{4})$', 'm')
const str = `1234-5678-9012-3412
5645-6789-7897-9879
87979879879798798
13156465487987
54654 231321 45654 464 3213 5464 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}