package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$`)
var str = `1234-5678-9012-3412
5645-6789-7897-9879
87979879879798798
13156465487987
54654 231321 45654 464 3213 5464 `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}