// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$").unwrap();
let string = "1234-5678-9012-3412
5645-6789-7897-9879
87979879879798798
13156465487987
54654 231321 45654 464 3213 5464 ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}